Quantcast

Anonymous port

classic Classic list List threaded Threaded
3 messages Options
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Anonymous port

Stéphane Lallée
Hi !

I have a program that opens several ports. When I run it from the command line everything is fine. However when I run it from yarprun (gyarpmanager) when the ports open I have this message :
yarp: Anonymous port active at tcp://10.29.32.104:38679
yarp: Anonymous port active at tcp://10.29.32.104:38680
yarp: Anonymous port active at tcp://10.29.32.104:38681
yarp: Anonymous port active at tcp://10.29.32.104:38682

I never encountered this "Anonymous" thing before. Any hint ?


Stéphane Lallée

*~~~~~~~~~~~~*
Synthetic, Perceptive, Cognitive and Emotive Systems (SPECS)
Universitat Pompeu Fabra
COMMUNICATION-POBLENOU CAMPUS (LA NAU building)
Roc Boronat, 138. 08018 Barcelona

http://specs.upf.edu/
*~~~~~~~~~~~~*

------------------------------------------------------------------------------

_______________________________________________
Robotcub-hackers mailing list
[hidden email]
https://lists.sourceforge.net/lists/listinfo/robotcub-hackers
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: Anonymous port

Stéphane Lallée
After investigating a bit it reveals that a getNameServerName() was returning "/root", while checknetwork() and detectNameServer() were failing.
My configured namespace is "/icub04", not /root. Althoug when ran from gyarpmanager it is getting root...
Then I tried forcing to set the nameserver from the code, before doing checknetwork() but this last still fails with the correct name.

I'm running yarprun and gyarpmanager on a windows 8 machine.

Any hint ?



Stéphane Lallée

*~~~~~~~~~~~~*
Synthetic, Perceptive, Cognitive and Emotive Systems (SPECS)
Universitat Pompeu Fabra
COMMUNICATION-POBLENOU CAMPUS (LA NAU building)
Roc Boronat, 138. 08018 Barcelona

http://specs.upf.edu/
*~~~~~~~~~~~~*


2014-04-04 8:48 GMT+02:00 Stéphane Lallée <[hidden email]>:
Hi !

I have a program that opens several ports. When I run it from the command line everything is fine. However when I run it from yarprun (gyarpmanager) when the ports open I have this message :
yarp: Anonymous port active at tcp://10.29.32.104:38679
yarp: Anonymous port active at tcp://10.29.32.104:38680
yarp: Anonymous port active at tcp://10.29.32.104:38681
yarp: Anonymous port active at tcp://10.29.32.104:38682

I never encountered this "Anonymous" thing before. Any hint ?


Stéphane Lallée

*~~~~~~~~~~~~*
Synthetic, Perceptive, Cognitive and Emotive Systems (SPECS)
Universitat Pompeu Fabra
COMMUNICATION-POBLENOU CAMPUS (LA NAU building)
Roc Boronat, 138. 08018 Barcelona

http://specs.upf.edu/
*~~~~~~~~~~~~*


------------------------------------------------------------------------------

_______________________________________________
Robotcub-hackers mailing list
[hidden email]
https://lists.sourceforge.net/lists/listinfo/robotcub-hackers
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: Anonymous port

paulfitz
Administrator

Sounds like the location for YARP's configuration files has become
ambiguous.  This happens from time to time on Windows, where the meaning
of the "home" directory is not as well defined.  Not sure what is
happening in your situation exactly, usually it is when there is some
mix of cygwin, eclipse, or something else that has an opinion about home
directories, but not sure what that would be in your case.  But anyway:
when you hit ambiguity, it is a good idea to set the YARP_CONF
environment variable globally to any directory you like and start over
so you can be sure everything on your system will be working from the
same configuration.
   http://wiki.icub.org/yarpdoc/yarp.html#yarp_conf

That's what I'd check first.
Cheers,
Paul

On 04/04/2014 02:47 PM, Stéphane Lallée wrote:

> After investigating a bit it reveals that a getNameServerName() was
> returning "/root", while checknetwork() and detectNameServer() were
> failing.
> My configured namespace is "/icub04", not /root. Althoug when ran from
> gyarpmanager it is getting root...
> Then I tried forcing to set the nameserver from the code, before doing
> checknetwork() but this last still fails with the correct name.
>
> I'm running yarprun and gyarpmanager on a windows 8 machine.
>
> Any hint ?
>
>
>
> Stéphane Lallée
>
> *~~~~~~~~~~~~*
> Synthetic, Perceptive, Cognitive and Emotive Systems (SPECS)
> Universitat Pompeu Fabra
> /COMMUNICATION-POBLENOU CAMPUS (LA NAU building)
> Roc Boronat, 138. 08018 Barcelona/
> http://specs.upf.edu/
> *~~~~~~~~~~~~*
>
>
> 2014-04-04 8:48 GMT+02:00 Stéphane Lallée <[hidden email]
> <mailto:[hidden email]>>:
>
>     Hi !
>
>     I have a program that opens several ports. When I run it from the
>     command line everything is fine. However when I run it from
>     yarprun (gyarpmanager) when the ports open I have this message :
>     yarp: Anonymous port active at tcp://10.29.32.104:38679
>     <http://10.29.32.104:38679>
>     yarp: Anonymous port active at tcp://10.29.32.104:38680
>     <http://10.29.32.104:38680>
>     yarp: Anonymous port active at tcp://10.29.32.104:38681
>     <http://10.29.32.104:38681>
>     yarp: Anonymous port active at tcp://10.29.32.104:38682
>     <http://10.29.32.104:38682>
>
>     I never encountered this "Anonymous" thing before. Any hint ?
>
>
>     Stéphane Lallée
>
>     *~~~~~~~~~~~~*
>     Synthetic, Perceptive, Cognitive and Emotive Systems (SPECS)
>     Universitat Pompeu Fabra
>     /COMMUNICATION-POBLENOU CAMPUS (LA NAU building)
>     Roc Boronat, 138. 08018 Barcelona/
>     http://specs.upf.edu/
>     *~~~~~~~~~~~~*
>
>


------------------------------------------------------------------------------
_______________________________________________
Robotcub-hackers mailing list
[hidden email]
https://lists.sourceforge.net/lists/listinfo/robotcub-hackers
Loading...