Compiling YARP bindings for use with C#

classic Classic list List threaded Threaded
2 messages Options
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Compiling YARP bindings for use with C#

Kate Paulinne
Hi All,

I'm new to iCub and YARP software, and currently trying to compile bindings so that I can use it with C# or MATLAB. I am using YARP 2.3.66 and iCub 1.4.0 installed from pre-compiled binaries. When I try to compile the bindings with CMake I get an error message saying:

"Could not find a configuration file for package "YARP" that is compatible
  with requested version "".
The following configuration files were considered but not accepted:

    C:/Program Files/robotology/yarp-2.3.66/cmake/YARPConfig.cmake, version: 2.3.66 (64bit)"

I was wondering if this may be due to installing different version of YARP previously that has been uninstalled?

I was trying to look in the CMakeLists file but can't figure out why exactly it is failing. Sorry if that question was already asked, I did find a few similar questions but none of them really helped me to figure out what's going wrong..

I was also trying to point CMake to specific YARP path on C drive, however this failed as well.

I would be grateful for any help with this.

Kind Regards,
Kate


------------------------------------------------------------------------------
Check out the vibrant tech community on one of the world's most
engaging tech sites, SlashDot.org! http://sdm.link/slashdot
_______________________________________________
Robotcub-hackers mailing list
[hidden email]
https://lists.sourceforge.net/lists/listinfo/robotcub-hackers
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: Compiling YARP bindings for use with C#

pattacini

Hello Kate,

 

Welcome to YARP community.

Would you mind opening an issue here https://github.com/robotology/yarp/issues?

 

For the reasons reported in https://github.com/robotology/QA/issues/118 we have been using GitHub rather than the mailing list for supporting users.

 

Thanks a lot and happy coding with YARP.

 

Best,

Ugo

 

 

From: Kate Paulinne [mailto:[hidden email]]
Sent: 24 February 2017 12:54
To: [hidden email]
Subject: [rc-hackers] Compiling YARP bindings for use with C#

 

Hi All,

 

I'm new to iCub and YARP software, and currently trying to compile bindings so that I can use it with C# or MATLAB. I am using YARP 2.3.66 and iCub 1.4.0 installed from pre-compiled binaries. When I try to compile the bindings with CMake I get an error message saying:

 

"Could not find a configuration file for package "YARP" that is compatible

  with requested version "".

The following configuration files were considered but not accepted:

 

    C:/Program Files/robotology/yarp-2.3.66/cmake/YARPConfig.cmake, version: 2.3.66 (64bit)"

 

I was wondering if this may be due to installing different version of YARP previously that has been uninstalled?

 

I was trying to look in the CMakeLists file but can't figure out why exactly it is failing. Sorry if that question was already asked, I did find a few similar questions but none of them really helped me to figure out what's going wrong..

 

I was also trying to point CMake to specific YARP path on C drive, however this failed as well.

 

I would be grateful for any help with this.

 

Kind Regards,

Kate

 


------------------------------------------------------------------------------
Check out the vibrant tech community on one of the world's most
engaging tech sites, SlashDot.org! http://sdm.link/slashdot
_______________________________________________
Robotcub-hackers mailing list
[hidden email]
https://lists.sourceforge.net/lists/listinfo/robotcub-hackers
Loading...