Problems of the lastest version of ICUB

classic Classic list List threaded Threaded
2 messages Options
Reply | Threaded
Open this post in threaded view
|

Problems of the lastest version of ICUB

zzhaoaa
I come across some problems in the lastest version the ICUB (MSVC 10 in Windows platform):

1. the home buttons do not work in the robotmotorgui (Error: No zero group found in the supplied file. Define a suitable head_zero)

2. The pitch roll yaw angles of the head keep increasing when there is not any command about head movement in the code, even if the program is not running. (same code works fine in ICUB v1.1.13)

3. The command positionMove(int j, double ref) works fine for j=3,4,5, while it doesn't work for j=0,1,2, corresponding to the  pitch roll yaw angles of the head.



Reply | Threaded
Open this post in threaded view
|

Re: Problems of the lastest version of ICUB

Marco Randazzo

1) in the current version of robotMotorGui, the configuration file robotMotorGui.ini has to contain the zero parameters. Your configuration file is probably missing of this section. As a quick fix, you can edit your file robotMotorGui.ini and add sections (one section for each part of the robot: head, left_arm, left_leg etc) similar to the one reported below. As an example you can also give a look to: icub-main\app\robots\iCubGenova03\robotMotorGui.ini

In the future robotMotorGui will ask the zeros directly to robotInterface.

 

[head_zero]   

//                          0             1             2             3             4             5   

PositionZero                0             0             0             0             0             0   

VelocityZero                10            10            10            10            10            10  

 

 

2-3) Very strange. Did you updated just your laptop or the whole system (server and pc104?)

Can you confirm that no other applications were running in background? (e.g. iKinGazeCtrl)

The most important point: can you send us a complete log of robotInterface?

 

 

-----Original Message-----
From: zzhaoaa [mailto:[hidden email]]
Sent: martedì 16 settembre 2014 16:13
To: [hidden email]
Subject: [rc-hackers] Problems of the lastest version of ICUB

 

I come across some problems in the lastest version the ICUB (MSVC 10 in Windows platform):

 

1. the home buttons do not work in the robotmotorgui (Error: No zero group found in the supplied file. Define a suitable head_zero)

 

2. The pitch roll yaw angles of the head keep increasing when there is not any command about head movement in the code, even if the program is not running. (same code works fine in ICUB v1.1.13)

 

3. The command positionMove(int j, double ref) works fine for j=3,4,5, while it doesn't work for j=0,1,2, corresponding to the  pitch roll yaw angles of the head.

 

 

 

 

 

 

 

--

View this message in context: http://robotcub-hackers.2198711.n2.nabble.com/Problems-of-the-lastest-version-of-ICUB-tp7579011.html

Sent from the RobotCub Hackers mailing list archive at Nabble.com.

 

------------------------------------------------------------------------------

Want excitement?

Manually upgrade your production database.

When you want reliability, choose Perforce.

Perforce version control. Predictably reliable.

http://pubads.g.doubleclick.net/gampad/clk?id=157508191&iu=/4140/ostg.clktrk

_______________________________________________

Robotcub-hackers mailing list

[hidden email]

https://lists.sourceforge.net/lists/listinfo/robotcub-hackers


------------------------------------------------------------------------------
Want excitement?
Manually upgrade your production database.
When you want reliability, choose Perforce.
Perforce version control. Predictably reliable.
http://pubads.g.doubleclick.net/gampad/clk?id=157508191&iu=/4140/ostg.clktrk
_______________________________________________
Robotcub-hackers mailing list
[hidden email]
https://lists.sourceforge.net/lists/listinfo/robotcub-hackers