Quantcast

YARP and ACE problems due to stricter gcc-4.3?

classic Classic list List threaded Threaded
1 message Options
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

YARP and ACE problems due to stricter gcc-4.3?

Jorge Scandaliaris-3
Hi,
Today I spent half a day debugging a previously-working application that
wouldn't build anymore. I can't give exact details because it only occured
later on to me that maybe all the problems were related to my recent
upgrade to gcc-4.3 (to gain openMP support).
To sum up, building my application ended up in an undefined reference:

/usr/lib/gcc/i686-pc-linux-gnu/4.3.3/../../../libYARP_OS.so: undefined
reference to `ACE_OS::fast_memcpy(void*, void const*, unsigned int)'

I believe at this point both YARP and ACE were built by gcc-4.1.xx. Upon
seeing the error I tried to rebuild ACE, version 5.5, which failed (wth
gcc-4.3). Then I tried to upgrade ACE to 5.6.5 which built OK. Then YARP
failed to build complaining of several undefined references. Then I tried
ACE-5.6.1 which failed to build.
Then I though about the gcc version, downgraded to 4.1.xx and build
successfuly ACE and YARP, and finally my application.

I though I'd post this experience as it may give hints about what's going
on with YARP and ACE in more recent releases of some distributions. BTW, I
run Gentoo 32 bits.

Jorge


------------------------------------------------------------------------------
Apps built with the Adobe(R) Flex(R) framework and Flex Builder(TM) are
powering Web 2.0 with engaging, cross-platform capabilities. Quickly and
easily build your RIAs with Flex Builder, the Eclipse(TM)based development
software that enables intelligent coding and step-through debugging.
Download the free 60 day trial. http://p.sf.net/sfu/www-adobe-com
_______________________________________________
Robotcub-hackers mailing list
[hidden email]
https://lists.sourceforge.net/lists/listinfo/robotcub-hackers
Loading...