Quantcast

Yarp/CMake update dependency errors on pc104 of iCubParis02

classic Classic list List threaded Threaded
2 messages Options
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Yarp/CMake update dependency errors on pc104 of iCubParis02

Ryan Lober-2
Hello there,

We were working on updating iCubParis02 and when trying to update CMake 2.8.7 to 2.8.9 (needed for the newest Yarp) we had some dependency errors:

The following packages have unmet dependencies:
     cmake : Depends: libarchive12 but it is not installable
             Depends: libc6 (>= 2.15) but 2.11.3-4 is to be installed
             Depends: libstdc++6 (>= 4.6) but 4.4.5-8 is to be installed
             Depends: libxmlrpc-core-c3 but it is not installable


Our current image on pc104 is version 3.2-oc with debian_version 6.0.7 and this should be the most recent non-BETA image available.

Should we try to upgrade to the 4.x Wheezy image or is there a simpler solution such as an apt-get upgrade?

Thank you in advance,

--
Ryan LOBER

Institut des Systèmes Intelligents et de Robotique
tel: +33.(0)6.58.14.68.12

------------------------------------------------------------------------------

_______________________________________________
Robotcub-hackers mailing list
[hidden email]
https://lists.sourceforge.net/lists/listinfo/robotcub-hackers
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: Yarp/CMake update dependency errors on pc104 of iCubParis02

Alberto Cardellino
The version 4 is actually been released at January and it is not beta anymore, I'll update the documentation about this.
The best is to keep syncronized with the last version of the usb image, so I'll suggest you to updated it and this should solve your issue.

Alberto


On 23/10/2014 16:46, Ryan Lober wrote:
Hello there,

We were working on updating iCubParis02 and when trying to update CMake 2.8.7 to 2.8.9 (needed for the newest Yarp) we had some dependency errors:

The following packages have unmet dependencies:
     cmake : Depends: libarchive12 but it is not installable
             Depends: libc6 (>= 2.15) but 2.11.3-4 is to be installed
             Depends: libstdc++6 (>= 4.6) but 4.4.5-8 is to be installed
             Depends: libxmlrpc-core-c3 but it is not installable


Our current image on pc104 is version 3.2-oc with debian_version 6.0.7 and this should be the most recent non-BETA image available.

Should we try to upgrade to the 4.x Wheezy image or is there a simpler solution such as an apt-get upgrade?

Thank you in advance,

--
Ryan LOBER

Institut des Systèmes Intelligents et de Robotique
tel: +33.(0)6.58.14.68.12


------------------------------------------------------------------------------

_______________________________________________
Robotcub-hackers mailing list
[hidden email]
https://lists.sourceforge.net/lists/listinfo/robotcub-hackers
Loading...