Quantcast

iCubInterface CAN protocol 1.2 instead of 1.1

classic Classic list List threaded Threaded
2 messages Options
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

iCubInterface CAN protocol 1.2 instead of 1.1

Maxime-Petit
Hi hackers,

After an update of the Yarp/iCub, I wanted to launch the robot but iCubInterface is reporting error

"It has been detected that your control boards are not using the same  CAN protocol used by iCubinterface."

I had updated them 3 weeks ago and they were fine (build 76/77). I have reinstalled them through the updateRobot.sh in the firmware directory but still nothing.

Then I spotted a detail : in the log, it says that iCubInterface CAN protocol is 1.2, but my robot and the associated firmware are 1.1 (See attach file)

However, I don't know how to change that, I have checked some .ini file in iCubLondon01 directory and in the cmake option, but have not found something which seems related to that.

Is there a way to force the protocol 1.1? Or there is an automatic detection which is somehow wrongly initialized?

Thank

./Max

------------------------------------------------------------------------------
Want fast and easy access to all the code in your enterprise? Index and
search up to 200,000 lines of code with a free copy of Black Duck
Code Sight - the same software that powers the world's largest code
search on Ohloh, the Black Duck Open Hub! Try it now.
http://p.sf.net/sfu/bds
_______________________________________________
Robotcub-hackers mailing list
[hidden email]
https://lists.sourceforge.net/lists/listinfo/robotcub-hackers

iCubLondon01-can-protocol.txt (28K) Download Attachment
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: iCubInterface CAN protocol 1.2 instead of 1.1

Marco Randazzo

You need to update the robot firmware to the latest firmware version which, unfortunately, has been released *after* your update of three weeks ago. Latest build is 80, not 77

Cheers,

=================================

Marco Randazzo,  PhD

iCub Facility

Italian Institute of Technology (IIT)

Via Morego 30

16163 Genova, Italy

www.iit.it

=================================

 

From: Maxime Petit [mailto:[hidden email]]
Sent: venerdì 1 agosto 2014 16:44
To: Robotcub-hackers
Subject: [rc-hackers] iCubInterface CAN protocol 1.2 instead of 1.1

 

Hi hackers,

 

After an update of the Yarp/iCub, I wanted to launch the robot but iCubInterface is reporting error

 

"It has been detected that your control boards are not using the same  CAN protocol used by iCubinterface."

 

I had updated them 3 weeks ago and they were fine (build 76/77). I have reinstalled them through the updateRobot.sh in the firmware directory but still nothing.

 

Then I spotted a detail : in the log, it says that iCubInterface CAN protocol is 1.2, but my robot and the associated firmware are 1.1 (See attach file)

 

However, I don't know how to change that, I have checked some .ini file in iCubLondon01 directory and in the cmake option, but have not found something which seems related to that.

 

Is there a way to force the protocol 1.1? Or there is an automatic detection which is somehow wrongly initialized?

 

Thank

 

./Max


------------------------------------------------------------------------------
Want fast and easy access to all the code in your enterprise? Index and
search up to 200,000 lines of code with a free copy of Black Duck
Code Sight - the same software that powers the world's largest code
search on Ohloh, the Black Duck Open Hub! Try it now.
http://p.sf.net/sfu/bds
_______________________________________________
Robotcub-hackers mailing list
[hidden email]
https://lists.sourceforge.net/lists/listinfo/robotcub-hackers
Loading...